namespace name 'progressBar' could not be found

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

namespace name 'progressBar' could not be found

Guest-32

Hi,

I've just found your component and downloaded it.  I've extracted it to my webdirectory and created it as a web application in IIS, I've opened it in .Net saved it and compiled it. and am getting the following error

C:\Inetpub\wwwroot\NeatUpload-1.0.12\Demo.aspx.cs(59): The type or namespace name 'progressBar' could not be found (are you missing a using directive or an assembly reference?)

I've not changed anything, all I'm trying to do is get your basic demo working

Any help would be greatly appreciated

Regards Allan

Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found

Guest-32

Hi Allan,

i had a similar error before.

Try this out first: http://www.brettle.com/ForumThreadView.aspx?thread=20&pageid=32&pageindex=7

to get the demo application running.

Just open the demo.aspx in the browser after.

 

 

Jason

Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found

Guest-32

Jason,

Thanks for your reply.  I've managed to get a demo working by creating my own instance and following the instructions in the manual.

So think I'm getting there.

Cheers Allan

Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found

Dean Brettle
Administrator
Hi Allan,

I'm glad to hear you got the Demo working, but I'm still concerned that you had the problem you described.  Did you modify something before trying to recompile (e.g. using src= as described in the thread Jason linked to)?  I don't have VS to test with, so I can't attempt to repro the problem.  But, with your help, I might be able to fix it for future releases.

Thanks,

--Dean
Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found

Guest-32

Dean,

I don't believe I changed anything. I downloaded extracted the zip to a temp folder, then copied neatupload-1.0.12 to my wwwroot opened iis set it as a website, opened vs pointed to NeatUpload.csproj.  Saved all then compiled and got the error i described above.

I've now binned the projected and recreated it from the temp directory and it now seems to work.  So it appears as though something got corrupted somehow.

I now have another question but will post it it separately

Cheers Al

Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found

Guest-32

@Dean @Allan

I just did and had done the same procedure Allan described now and i got no problem at all recompiling it.

I didnt changed anything too.

Just opened the NeatUpload.csproj and created a new .sln File for the project.

I even didnt need to set the NeatUpload Folder as a website ! SO, maybe this is the problem, i just copied it in the wwwroot folder and opened the csproj with VS 2003 Prof. on Win XP Prof.

 

Jason. // (i just a different problem if the user cancels the upload progress)

Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found

Dean Brettle
Administrator
Looks like this remains a mystery.  If either of you or anyone else manages to reproduce the problem, try re-building the project (or cleaning and building it) instead of just building it and post here whether that fixes the problem. If it does, then perhaps the prebuilt bin\Brettle.Web.NeatUpload.dll is confusing VS.

--Dean
Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found

RunningBeare

Dean,

I always use rebuild solution so that didn't solve it, however I have read that sometimes deleting the bin directory then rebuilding can solve these glitches.

Cheers Allan

Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found

Jon G
I ran into something similar when I first started using NeatUpload.  Chech the thread over here and see if it helps...

http://www.brettle.com/ForumThreadView.aspx?thread=14&pageid=32&pageindex=7

Reply | Threaded
Open this post in threaded view
|

Re: namespace name 'progressBar' could not be found ***Resolved**

RunningBeare

Jon,

Thanks, I think I must have chosen yes when asked to create the codebehind.

Cheers Al