The 1st time of multiple files uploading is OK, but not the 2nd time.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

The 1st time of multiple files uploading is OK, but not the 2nd time.

Guest-965
Hi Dean,

I am using the MultiFile control to select several files at same time and click "Submit" button to upload the files. It works fine. Now, I want to upload more files. So, I click "Pick Files" again and select new files and click "Submit" button. Nothing happens. So, the 2nd time of file uploading does not work. The work around is that I redirect application to the same page using the same URL (i.e., Response.Redirect(Request.Url.ToString());). If no redirect, I cannot do multiple times of file uploading. Please help. Thanks.

Stock
Reply | Threaded
Open this post in threaded view
|

Re: The 1st time of multiple files uploading is OK, but not the 2nd time.

Dean Brettle
Administrator
What version of NeatUpload are you using?  Can you post or email me (dean at brettle dot com) the aspx and code-behind for the upload page?

--Dean
Reply | Threaded
Open this post in threaded view
|

Re: The 1st time of multiple files uploading is OK, but not the 2nd time.

Dean Brettle
Administrator
I never received anything.  If you sent it, it might have been bounced by a virus scanner.  Please use a one-click hosting service to send me (dean at brettle dot com) a small test app that demonstrates the issue.
Reply | Threaded
Open this post in threaded view
|

Re: The 1st time of multiple files uploading is OK, but not the 2nd time.

Guest-965
This issue is found to occur in IE only. It works fine in other browsers. The demo http://www.brettle.com/Demo.aspx itself has this error
Reply | Threaded
Open this post in threaded view
|

Re: The 1st time of multiple files uploading is OK, but not the 2nd time.

Dean Brettle
Administrator
I've tried to reproduce the problem you describe but everything seems to be working fine.  I point IE8 at http://www.brettle.com/Demo.aspx, use either MultiFile control to select 3 jpg images, click submit, wait for the upload to complete, select 3 more jpg images, click submit, and the upload still works fine.  I'm not sure what you are doing that is different. 

What version of IE8,  Flash, and Windows are you using?  I'm using IE 8.0.6001.18783 and Flash version 10,0,22,87 on Windows Vista.

Can you create a screencast that shows exactly what you are doing so I can look for differences?

If anyone else is having this problem, please speak up so we can get it figured out.

--Dean
Reply | Threaded
Open this post in threaded view
|

Re: The 1st time of multiple files uploading is OK, but not the 2nd time.

Guest-965
The problem occured in IE 8 beta 2. When i upgrade IE it worked fine