Proress bar not working in multi-file upload in firefox 3.0

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Proress bar not working in multi-file upload in firefox 3.0

Gary Dryden

I have the progress bar working in multi-file mode under IE and Safari.

When I try with firefox (using firebug), I get an error on this line:

var status = templates.item(0).getAttribute('status');

Thats because the previous line:

var templates = responseXmlDoc.getElementsByTagName('neatUploadDetails');

resulted in templates being null

I looked at the content of responseXmlDoc and it looked fine.

What is the problem.

Reply | Threaded
Open this post in threaded view
|

Re: Proress bar not working in multi-file upload in firefox 3.0

Dean Brettle
Administrator
Are you using the Progress.aspx included with the release or have you customized it in some way?

--Dean
Reply | Threaded
Open this post in threaded view
|

Re: Proress bar not working in multi-file upload in firefox 3.0

Guest-967
just the standard
Reply | Threaded
Open this post in threaded view
|

Re: Proress bar not working in multi-file upload in firefox 3.0

Dean Brettle
Administrator
What version of ASP.NET are you using?  Or are you using Mono?

Also, what version of NeatUpload are you using?

--Dean
Reply | Threaded
Open this post in threaded view
|

Re: Proress bar not working in multi-file upload in firefox 3.0

Guest-967

I am using MONO,

neatUpload V 1.3.12

Can you reproduce this?

It seems tome that getElementByTagName is not working in ff, because when I look at the string returned, the requested tagname is sure there.

Thanks for your effort.

Reply | Threaded
Open this post in threaded view
|

Re: Proress bar not working in multi-file upload in firefox 3.0

Dean Brettle
Administrator
See this bug. I think upgrading to the latest stable mono will fix the problem. --Dean