Progress Bar not automatically starting

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Progress Bar not automatically starting

Alan
The progress bar is not automatically starting. If I have Inline="true", I can hit the refresh button and it will start showing the updates. If the progress bar is not set to inline, I will never see any indication of a progress bar. If I drop the demo.apsx into my Visual Studios solution, I can never see a progress bar.

I am running the site from Visual Studios 2008.
NeatUpload Version: 1.3.21

Files added to Bin:
Brettle.Web.NeatUpload.dll
Brettle.Web.NeatUpload.pbd

My simple ASP test page.
<nu:progressbar ID="Progress" runat="server" Inline="true" />
<br />
<nu:inputfile ID="FileUpload" runat="server" />
<br />
<asp:Button ID="SubmitButton" runat="server" Text="Sumbit" OnClick="SubmitButton_Click" />

Added to my web.config:
<configSections>
  ...
  <section name="neatUpload" type="Brettle.Web.NeatUpload.ConfigSectionHandler, Brettle.Web.NeatUpload" allowLocation="true" />
</configSections>

<httpModules>
  <add name="UploadHttpModule" type="Brettle.Web.NeatUpload.UploadHttpModule, Brettle.Web.NeatUpload" />
  ...
</httpModules>

I'm not sure if this is a web garden/farm issue, since I am able to view the update progress after hitting the refresh button on the progress bar.

Everything else is working great. Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: Progress Bar not automatically starting

Dean Brettle
Administrator
This sounds like either JavaScript is disabled in the browser or a JavaScript error is occuring.   Also, what browser version are you using?

--Dean
Reply | Threaded
Open this post in threaded view
|

Re: Progress Bar not automatically starting

Guest-1112
FireFox 3.6. Javascript is enabled, but I am receiving the following javascript errors from the error console:
Error: NeatUploadPB is not defined
Error: NeatUploadInputFileCreate is not defined
Reply | Threaded
Open this post in threaded view
|

Re: Progress Bar not automatically starting

Dean Brettle
Administrator
Please double check that you followed the instructions for Installing NeatUpload, in particular step #7.
Reply | Threaded
Open this post in threaded view
|

Re: Progress Bar not automatically starting

Alan
I'm using the Visual Studios development server, so I don't think I can actually set the folder to have anonymous access. I will have to install IIS.

Thanks for the help!
Reply | Threaded
Open this post in threaded view
|

Re: Progress Bar not automatically starting

Alan
I have all the permissions set correctly (as far as I can tell) and I am still receiving the javascript errors. I disable the windows authentication and the anonymous user has script read/execute permissions on the folder. Any other things to try?