Differences Uploading with IE and Mozilla

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Differences Uploading with IE and Mozilla

Guest-30

Hi,

im using the Version 1.0.12 and i tested the Uploading with IE and Mozilla and i (still) seeing some differences here.

First of all, both Browsers work properly on localhost, testing it on the same PC.

On Lan (maybe Internet too then) its different:

With Mozilla everything is fine ! Thats the good thing.

But with IE the Upload with large files is extremely slow... on Mozilla i need like ~1 min. for a 500 MB File, but on IE its like 1,5 Hours. ;)

Well im not sure if you're aware of this. So i thought to mention it again. :)

Thanks.

Reply | Threaded
Open this post in threaded view
|

Re: Differences Uploading with IE and Mozilla

Dean Brettle
Administrator
Hi,

I'm not sure what's causing the IE-specific slowness you are seeing.  FWIW, I just uploaded a 575MB file over my LAN from both IE and Mozilla Firefox.  It took about 10min in both cases.  That was uploading to NeatUpload running on Mono/XSP 1.1.9.2 on Linux.  I don't have an IIS/.NET installation where I can upload such large files, so I can't really test it there. 

Does the problem still occur if you remove the UploadHttpModule from your web.config?  If it does that it isn't associated with NeatUpload.  It's either IIS/.NET or your particular IE installation.  I'm guessing the latter.  Does the problem occur if you try to upload from other computers using IE?

--Dean

PS.  Are you the same user who posted about slow uploads with IE in this other thread?
Reply | Threaded
Open this post in threaded view
|

Re: Differences Uploading with IE and Mozilla

Guest-30

Umm, strange, yeah you could be right, maybe it is .NET or IIS related.

I have Windows XP Prof. on both PCs. Both are fully updated. IE (6.0 SP2) and Mozilla and connected via Lan.

NeatUpload is running on Windows XP Prof., IIS 5.1 and 1 GB Ram, AMD 64 3500+.

If i remove the HttpModule from my web.config, i cant even Upload big files, internal error 500 occuring, same with Mozilla. Its the old error why i switched to NeatUpload.

Unfortunately i dont have other PCs around, so i just have these 2 available.

And yes, im the user in the linked thread. :)

Well, everything working fine atm, maybe i just tell everyone to use Mozilla...

 

Reply | Threaded
Open this post in threaded view
|

Re: Differences Uploading with IE and Mozilla

Guest-30

Hello there!

unfortunately i've the same problem. I've tested version 1.1.1 as well but i's still the same. I've tested it on my companies LAN and saw that on "some" machine upload works really slow with ie. The funny thing is, it works perfectly on the same machines when you try with mozilla or opera. And, on the other hand, it works fine with ie on other machines.

 

I'm quite puzzled. What else i can try? Do you have any idea?

thank you very much...

Gokhan KORALTURK / Turkey

Reply | Threaded
Open this post in threaded view
|

Re: Differences Uploading with IE and Mozilla

Dean Brettle
Administrator
Does this upload test page report more reasonable upload speeds for the machines where you are having the problem?

Are the machines where you are seeing the problem running the same version of IE and Windows as the machines where you aren't seeing the problem?

Do the problem machines have any firewall software installed?  If so, you might try disabling or even uninstalling it temporarily.

During the slow upload, what does the client machine's CPU utilization look like?

FWIW, a google search for "IE slow upload" found several reports of similar behavior but no common solutions.

--Dean